just so ya know…

…if you’re using mod_python and Apache 1.x do not, under any circumstance, upgrade to gcc 4. Bad things happen to your server.

Also, don’t tell me I should be using Apache 2. I know that. I may make zulu upgrade his code, because that’s really the only reason why we aren’t.

But still – Apache 1.x, mod_python, libc6, and gcc 4 are really bad news. So don’t. No, seriously, don’t.

I’ll post more on this a little later (along with how to make mod_myasql_auth actually work with Apache 2.3.x), but I just wanted to say that after three months of the webserver here taking a dump on a regular basis since upgrading Debian, the problem is solved. mod_python was the culprit, and it has been sent to its room.

Thanks to the squid-folk for their patience while their sites dropped off the map for no apparent reason several times a week and I couldn’t figure out what was going on. All better now. Teh yay!

2 thoughts on “just so ya know…

  1. modified snakes, even. the funny part is, they weren’t being used, yet still causing problems. turfing their lazy asses out was the solution :)

Leave a Reply

Your email address will not be published.