Adobe Security Updates for Flash, Reader, and Shockwave Plugins (plus bonus Silverlight & Java updates)

On June 14th 2011 Adobe released updates for its Flash, Reader, and Shockwave plugins to address critical security vulnerabilities in those products. Also getting in on the update fun recently was Microsoft, with a new version of Silverlight and Oracle, who released an update to Java last week that addressed 17 security vulnerabilities.

If you use any of these plugins, you should update them as soon as possible.

If you are unsure of what plugins you have installed and whether they need to be updated, you can visit Mozilla’s Plugin Check. Plugin Check is a web app which helps you identify what plugins you have installed, whether they need to be updated, and where to get the updates.

Related Links:

One thought on “Adobe Security Updates for Flash, Reader, and Shockwave Plugins (plus bonus Silverlight & Java updates)

  1. Thanks for the reminder, turns out Flash wasn’t up to date even though the updater ran the other morning. Worrying!

Leave a Reply

Your email address will not be published.